• Mikko
    We are testing the camera with Huawei P9 phone. We installed the apps without problems and it looks like the camera is connected to the app but when selecting Scan Face, there's only a blank screen (like this: https://drive.google.com/open?id=1QbO2KPBFVMqAq0XDVpVu8GVzdLpaaHK1). We can see two faint red lights flickering between the left-most and center "cameras" on the device but we are not able to see scan preview and we are not able to scan the face. Any ideas what we could do? Our phone is running Android version 7.0.

  • Alex Preston
    Hey ,
    We currently have not tested that phone. But to get a better understanding of the situation, could you answer a few questions for me. Just to make sure you have downloaded both the Bellus3D Service, and the Bellus3D FaceCamera app? When you plugged in the Camera did you get a prompt to "Use by Default for this USB Device" from the Bellus3DService? You will have to select "Use by Default for this USB Device" twice. If you did not get prompted twice, the camera won't be fully connected. Let me know if you still have issues, and we will continue to try to help you. Thanks!

  • Mikko
    I downloaded both apps and I did get that prompt twice and I chose Use by default... on both times. At first run the app complained that I had less than 3Gb storage left. I then changed my phone's settings to use external SD card as default storage and then the app no longer complained about storage space (I have 10Gb free space on my SD card). Is there something valuable in my device's log (using "adb logcat" function) that might be of use to you to figure out what's going on?
  • Admin

    Hi Mikko,
    The release version of the app in Google Play Store won't be able to log out any adb logs from our app. I don't think we have ever tried to store data on SD card. But I am not sure if that is the problem. Is it possible to try to leave more than 3GB space on your phone and try again? I am trying to eliminate any unknown issues here.
  • MikkoAccepted Answer
    After some sacrifices, I managed to clear enough storage on the phone's main storage. After that I changed phone's settings so that it uses phone storage by default. I then force stopped bellus service app and cleared its defaults. Then connected the camera and answered twice to the usb question and started the scan app. Still no luck: app now said: "connecting camera... camera disconnected."

    I then force stopped both apps, cleared defaults on the service app. cleared all data for both apps and connected the camera again. Answered the usb question twice, then started the scan app. allowed it to access my camera and files. then started scanning and it worked!

    So it looks like it the problem was related to using the SD card instead of phone's internal storage. But it did require that I cleared everything after changing the phone's settings to use internal storage.
  • Admin

    Hi Mikko,
    Great job! And thanks for letting us know about this problem, we will add that notation to our User Guide.
    In the mean time, we will explore more about the SD card support. It requires more testing.
    Have fun with the camera then~
Add a Comment

Welcome to Bellus3D Face Camera Pro Support Forum!

You can visit Bellus3D.com/support to register your product and get an invitation email to join this forum.